Configuring Cos Maps - Cisco Catalyst 2950 Software Configuration Manual

Hide thumbs Also See for Catalyst 2950:
Table of Contents

Advertisement

Configuring Standard QoS
This example shows how to create a policy map and attach it to an ingress interface. In the configuration,
the IP standard ACL permits traffic from network 10.1.0.0. For traffic matching this classification, the
DSCP value in the incoming packet is trusted. If the matched traffic exceeds an average traffic rate
of 5000000 bps and a normal burst size of 8192 bytes, its DSCP is marked down to a value of 10 and sent.
Switch(config)# access-list 1 permit 10.1.0.0 0.0.255.255
Switch(config)# class-map ipclass1
Switch(config-cmap)# match access-group 1
Switch(config-cmap)# exit
Switch(config)# policy-map flow1t
Switch(config-pmap)# class ipclass1
Switch(config-pmap-c)# police 5000000 8192 exceed-action dscp 10
Switch(config-pmap-c)# exit
Switch(config-pmap)# exit
Switch(config)# interface gigabitethernet0/1
Switch(config-if)# switchport mode access
Switch(config-if)# service-policy input flow1t
This example shows how to create a Layer 2 MAC ACL with two permit statements and attach it to an
ingress interface. The first permit statement allows traffic from the host with MAC
address 0001.0000.0001 destined for the host with MAC address 0002.0000.0001.
Switch(config)# mac access-list extended maclist1
Switch(config-ext-mac)# permit host 0001.0000.0001 host 0002.0000.0001
Switch(config-ext-mac)# exit
Switch(config)# mac access-list extended maclist2
Switch(config-ext-mac)# permit host 0001.0000.0003 host 0002.0000.0003
Switch(config-ext-mac)# exit
Switch(config)# class-map macclass1
Switch(config-cmap)# match access-group name maclist1
Switch(config-cmap)# exit
Switch(config)# policy-map macpolicy1
Switch(config-pmap)# class macclass1
Switch(config-pmap-c)# set ip dscp 56
Switch(config-pmap-c)# exit
Switch(config-pmap)# class macclass2 maclist2
Switch(config-pmap-c)# set ip dscp 48
Switch(config-pmap-c)# exit
Switch(config-pmap)# exit
Switch(config)# interface gigabitethernet0/1
Switch(config-if)# switchport mode trunk
Switch(config-if)# mls qos trust cos
Switch(config-if)# service-policy input macpolicy1

Configuring CoS Maps

This feature is available only if your switch is running the EI.
Note
This section describes how to configure the CoS maps:
All the maps are globally defined.
Catalyst 2950 and Catalyst 2955 Switch Software Configuration Guide
29-34
Configuring the CoS-to-DSCP Map, page 29-35
Configuring the DSCP-to-CoS Map, page 29-36
Chapter 29
Configuring QoS
78-11380-12

Hide quick links:

Advertisement

Table of Contents
loading

This manual is also suitable for:

Catalyst 2955

Table of Contents